Planilhas Inteligentes (Função PROCV)

Informática Geral SQL
Planilhas Inteligentes (Função PROCV)
Carlos Roa
em 28 de Abril de 2014

Bom dia, Turma!

 

1. Bate Papo Rápido

A função PROCV, com certeza, é uma das funções de busca mais famosas e requisitadas do Excel; é aquela que, em uma entrevista de emprego, perguntam-lhe se você conhece, sendo, muitas vezes, um fator de desempate ou até mesmo de contratação.

Sabe por que as funções de busca do Excel são tão importantes?

Elas são importantes porque executam a mesma função das grandes plataformas de bancos de dados como, SQL e Oracle, no entanto, de uma forma mais primitiva, restrita e limitada.

Podemos evidenciar este fato quando condicionamos as funções de busca com a intenção de torná-las mais sofisticadas, imagine, por exemplo, que eu queira pesquisar todos os nomes que terminam com a letra "a" e sejam do sexo feminino. Utilizando a função PROCV, isso seria um pouco trabalhoso, pois teriamos que combinar alguams técnicas para se atingir um resultado satisfatório.

Vamos entender um pouco melhor o uso da função PROCV e perceber a sua importância.

 

2. Sintaxe da Função

=PROCV(valor_procurado;matriz_tabela;núm_índice_coluna;procurar_intervalo)

A função PROCV é a mais utilizada pelos usuários pelo simples fato de estarmos habituados a alimentar uma base de dados na VERTICAL, ou seja, de cima para baixo, ao invés da esquerda para direita, na HORIZONTAL, neste caso aplicariamos a função PROCH.

valor_procurado = valor de referência para a busca

matriz_tabela = matriz a ser varrida no momento da busca

núm_índice_coluna = O valor de referência sempre estará na coluna de valor 1, então, se quisermos buscar os dados das colunas subsequentes devemos inserir 2 para segunda coluna , 3 para a terceira e assim por diante.

procurar_intervalo = Esta relacionado com o tipo de busca, exata ou aproximada. Como geralmente as buscas são exatas, neste campo se coloca 0 ou FALSO.  Em caso contrário 1 ou VERDADEIRO, por exemplo, tem-se um controle de despesas, mas quero que retorne a partir de um valor aproximado o tipo de fatura.

 

3. Aplicação do Conceito

Importante: Para copiar as tabelas de forma efetiva, pressione o Crtl e selecione os campos de interesse, delimitados entre os rólutos númericos das linhas e alfabéticos das colunas.

- A B C D
1 SISTEMA DE BUSCA (LOJA/CLIENTE)
2 B =PROCV(A2;$A$6:$B$8;2;0) =PROCV(A2;$A$6:$C$8;3;0) =PROCV(A2;$A$6:$D$8;4;0)
3 G =PROCV(A3;$A$10:$B$12;2;0) =PROCV(A3;$A$10:$C$12;3;0) =PROCV(A3;$A$10:$D$12;4;0)
4 DADOS
5 LOJA ESTADO CIDADE SEGMENTO
6 A São Paulo Guarulhos Energia Elétrica
7 B Minas Gerais Belo Horizonte Mineração
8 C Rio de janeiro Penedo Petroquímico
9 CLIENTE VENDEDOR PRODUTO PRAZO DE ENTREGA
10 E X ALFA 01/10/2013
11 F Y BETA 02/10/2013
12 G Z GAMA

03/10/2013

 

- A B C D
1 SISTEMA DE BUSCA (LOJA/CLIENTE)
2 B Minas Gerais Belo Horizonte Mineração
3 G Z GAMA 03/10/2013
4 DADOS
5 LOJA ESTADO CIDADE SEGMENTO
6 A São Paulo Guarulhos Energia Elétrica
7 B Minas Gerais Belo Horizonte Mineração
8 C Rio de janeiro Penedo Petroquímico
9 CLIENTE VENDEDOR PRODUTO PRAZO DE ENTREGA
10 E X ALFA 01/10/2013
11 F Y BETA 02/10/2013
12 G Z GAMA

03/10/2013

No exemplo acima, podemos perceber que quando mudados o valor procurado em  (A, B ou C) é executado uma nova busca de acordo com os dados.

Obs.: A função PROCV não efetua buscas inversas, ou seja, da direita para esquerda, esta é uma grave limitação desta função e que poderá ser solucionado com a aplicação da função ÍNDICE + CORRESP.

 

Um grande abraço a todos,

Carlos Roberto Roa

São Paulo / SP
Curso Livre: Microsoft Excel Avançado (Acadêmicos do Excel)
Graduado em Engenharia de Produção Mecânica pelo Instituto Mauá de Tecnologia (IMT) atuo com Inteligência de Mercado e administro o site Acadêmicos do Excel, ambiente com um vasto conteúdo de ensino sobre Excel. Já ministrei aulas particulares e suporte em cursinho pré vestibular em Matemática e Física. Sou uma pessoa comunicativa, paciente e apaixonada por exatas e tecnologia. No momento estou me especializando em tecnologias de Big Data. Estou a disposição para maiores informações!
Excel para Vestibular, Excel Profissional, Análise de Dados em Excel, Matemática para Ensino Fundamental, Física para Ensino Fundamental, Física para Ensino Médio, Física para ENEM
Oferece aulas presenciais
R$ 70 / aula
Conversar
Cadastre-se ou faça o login para comentar nessa publicação.

Listas de exercícios, Documentos, Revisões de textos, Trabalhos?

Se seu problema for dificuldade em uma lista de exercícios, revisão de teses e dissertações, correção de textos ou outros trabalhos, peça uma ajuda pelo Tarefas Profes.

Enviar Tarefa

Confira artigos similares

Confira mais artigos sobre educação

Ver todos os artigos

Encontre um professor particular

Busque, encontre e converse gratuitamente com professores particulares de todo o Brasil