Planilhas Inteligentes (Função DIA.DA.SEMANA)

Informática Geral Outlook E-Mail
Planilhas Inteligentes (Função DIA.DA.SEMANA)
Carlos Roa
em 28 de Abril de 2014

Bom Dia, Turma!

 

1. Bate Papo Rápido

A administração de uma agenda e organização de datas em atividades cotidianas torna-se imprescindível em pleno século XXI, já que não temos controle do tempo. A tecnologia vem, cada vez mais, auxilando-nos quanto ao tempo dispendido em diversas atividades, por exemplo, o Facebook já nos lembra dos aniversários de nossos amigos, os celulares programam despertadores para nos acordar e tomar o lanche da tarde, as instituições financeiras enviam lembretes de pagamento por e-mail ou sms e o Outlook nos comunica a cada 5 minutos de uma reunião logo cedo. Como dizem os americanos: Time is Money!

A função DIA.DA.SEMANA() veio exatamente para organizar e programar datas de eventos importantes de uma forma rápida e dinâmica, estou exagerando, mas imagine 15/07/2017, você sabe em qual dia da semana cairá? Sei que existe muita gente que faz cálculos rápidos e, provavelmente, com um pouco de esforço, chegará à conclusão que cai no sábado.

Como disse desde de o início, tempo é algo que não temos controle e não podemos desperdiçá-lo, aliás devemos otimizá-lo, devido a demanda de atividades do dia-a-dia.

Com essa ideia de tempo, vamos expor alguns conceitos da função:

 

2. Sintaxe da Função

=DIA.DA.SEMANA(núm_série,[retornar_tipo])

O Excel somente entende datas após 1º janeiro de 1900, datas anteriores a esta somente com Macro. A interpretação do Excel quanto a data é que em 01/01/1900 é o marco zero, por exemplo, quando digitamos 28/04/2014 aparece 41757 (número de dias transcorridos após o marco zero).

O "número_série" é um valor inteiro que é definido pelo "[retornar_tipo]", temos:

[retornar_tipo]: 1 ou vazio, número de série deverá ser entre 1 (domingo) e 7 (sábado)

[retornar_tipo]: 2, número de série deverá ser entre 1 (segunda-feira) e 7 (domingo)

[retornar_tipo]: 3, número de série deverá ser entre 0 (segunda-feira) e 6 (domingo)

 

3. Aplicação do Conceito

Importante: Para copiar as tabelas de forma efetiva, pressione o Crtl e selecione os campos de interesse, delimitados entre os rólutos númericos das linhas e alfabéticos das colunas.

Mostrarei duas formas difrentes para construirmos um controle para sabermos os dias da semana, no caso abaixo, utilizarei a função HOJE() que retornará a data atual.

1º Modo

- A B
1 MOSTRA OS DIAS DA SEMANA
2 DATA: =HOJE()
3 DIA DA SEMANA:

=SE(DIA.DA.SEMANA(B2)=1;"domingo";SE(DIA.DA.SEMANA(B2)=2;"segunda"; SE(DIA.DA.SEMANA(B2)=3;"terça";SE(DIA.DA.SEMANA(B2)=4;"quarta"; SE(DIA.DA.SEMANA(B2)=5;"quinta";SE(DIA.DA.SEMANA(B2)=6;"sexta";"sábado"))))))

Obs.: Como o Excel suporta no máximo 7 aninhamentos condicionais "se"; no exemplo acima, não foi explorado o limite de condicionais, por conveniência e praticidade.

2º Modo

- A B
1 MOSTRA OS DIAS DA SEMANA
2 DATA: =HOJE()
3 DIA DA SEMANA:

=TEXTO(DIA.DA.SEMANA(B2;1);"dddd")

Obs. 1: A função TEXTO() precisa conhecer o valor e o formato a ser visualizado, no caso acima, a função HOJE() retorna o valor da data atual e o formato exibido será, dia da semana ("dddd").

Obs. 2: Repare que a função DIA.DA.SEMANA(B2)=DIA.DA.SEMANA(B2;1).

 

4. Desafio

Implemente a função para mostrar a data e o horário das reuniões diárias na sua empresa!

Dica: Use a função TEMPO().

 

Um grande abraço a todos,

Carlos Roberto Roa

São Paulo / SP
Curso Livre: Microsoft Excel Avançado (Acadêmicos do Excel)
Graduado em Engenharia de Produção Mecânica pelo Instituto Mauá de Tecnologia (IMT) atuo com Inteligência de Mercado e administro o site Acadêmicos do Excel, ambiente com um vasto conteúdo de ensino sobre Excel. Já ministrei aulas particulares e suporte em cursinho pré vestibular em Matemática e Física. Sou uma pessoa comunicativa, paciente e apaixonada por exatas e tecnologia. No momento estou me especializando em tecnologias de Big Data. Estou a disposição para maiores informações!
Excel para Vestibular, Excel Profissional, Análise de Dados em Excel, Matemática para Ensino Fundamental, Física para Ensino Fundamental, Física para Ensino Médio, Física para ENEM
Oferece aulas presenciais
R$ 70 / aula
Conversar
Cadastre-se ou faça o login para comentar nessa publicação.

Listas de exercícios, Documentos, Revisões de textos, Trabalhos?

Se seu problema for dificuldade em uma lista de exercícios, revisão de teses e dissertações, correção de textos ou outros trabalhos, peça uma ajuda pelo Tarefas Profes.

Enviar Tarefa

Confira artigos similares

Confira mais artigos sobre educação

Ver todos os artigos

Encontre um professor particular

Busque, encontre e converse gratuitamente com professores particulares de todo o Brasil