Encontrando dados iguais e separando diferentes

Olá, gostaria de saber se existe alguma fórmula que possa comparar os dados da coluna A e B e quando encontrar um dado da coluna A que não tenha na coluna B, ele coloque este dado na coluna C.
OBS: tanto a coluna A quanto a B os dados são números

Exemplo:
coluna A coluna B Coluna com a fórmula
123 123 258
321 321
369 369
147 147
258

Thiago Albini Braga
Thiago
perguntou há 7 dias

Sabe a resposta?

Ganhe 10 pts por resposta de qualidade
Nome
Sobrenome
E-mail

Seu e-mail não será divulgado

2 respostas
Professor Kelvin Oliveira
Respondeu há 6 dias
Melhor resposta
Melhor resposta escolhida pelo autor da dúvida
Olha Thiago, sou apenas um entusiasta do excel. Não possuo formação técnica então vamos tentar resolver com o jeitinho brasileiro. Enquanto ninguém responde o meu jeito pode lhe servir de algum modo. Só que a resposta em C vai dar na mesma linha que houver o valor não coincidente e não no início, mas se você filtrar as colunas consegue achar esses valores facilmente. Outra, eu defini como sendo 0(zero) o valor das células normais, caso você queira o zero vai ter que fazer uma alteraçãozinha.
=SEERRO(PROCV(A2;B:B;1;(FALSO))*0;A2)
A fórmula é essa. Coloca isso no C2 e arrasta até onde achar conveniente, pelo menos até onde tiver valores de A. Qualquer coisa me manda uma mensagem com seu e-mail que eu te mando um exemplo.
Professor Carlos Roa
Respondeu há 3 dias
Olá Thiago, uma forma bem pratica para se resolver este caso em específico é o seguinte:

Aplicando-se a fórmula em C1:

=SE(EXATO(A1;B1);"";SE(A1="";B1;A1))

Interpretando a fórmula:
SE o valor A1 e B1 forem EXATAMENTE IGUAIS retorne vazio, caso contrário, SE A1 for igual a vazio, retorne B1 ao contrário A1.

Caso tenha interesse em aprender mais sobre Excel e novos conteúdos acompanhe o meu trabalho no site:
www.academicosdoexcel.com.br

Também compartilho o conteúdo no meu Blog no ambiente Profes.

Um grande abraço,

Professores particulares de Excel

+ Ver todos
Encontre e contrate um professor particular para te ajudar nos estudos.

Pergunte aos nossos professores