Encontrando dados iguais e separando diferentes

Olá, gostaria de saber se existe alguma fórmula que possa comparar os dados da coluna A e B e quando encontrar um dado da coluna A que não tenha na coluna B, ele coloque este dado na coluna C.
OBS: tanto a coluna A quanto a B os dados são números

Exemplo:
coluna A coluna B Coluna com a fórmula
123 123 258
321 321
369 369
147 147
258

Thiago A.
Thiago
perguntou há 1 ano

Sabe a resposta?

Ganhe 10 pts por resposta de qualidade
2 respostas
Professor Kelvin O.
Respondeu há 1 ano
Melhor resposta
Melhor resposta escolhida pelo autor da dúvida
Olha Thiago, sou apenas um entusiasta do excel. Não possuo formação técnica então vamos tentar resolver com o jeitinho brasileiro. Enquanto ninguém responde o meu jeito pode lhe servir de algum modo. Só que a resposta em C vai dar na mesma linha que houver o valor não coincidente e não no início, mas se você filtrar as colunas consegue achar esses valores facilmente. Outra, eu defini como sendo 0(zero) o valor das células normais, caso você queira o zero vai ter que fazer uma alteraçãozinha.
=SEERRO(PROCV(A2;B:B;1;(FALSO))*0;A2)
A fórmula é essa. Coloca isso no C2 e arrasta até onde achar conveniente, pelo menos até onde tiver valores de A. Qualquer coisa me manda uma mensagem com seu e-mail que eu te mando um exemplo.
Professor Carlos R.
Respondeu há 1 ano
Olá Thiago, uma forma bem pratica para se resolver este caso em específico é o seguinte:

Aplicando-se a fórmula em C1:

=SE(EXATO(A1;B1);"";SE(A1="";B1;A1))

Interpretando a fórmula:
SE o valor A1 e B1 forem EXATAMENTE IGUAIS retorne vazio, caso contrário, SE A1 for igual a vazio, retorne B1 ao contrário A1.

Caso tenha interesse em aprender mais sobre Excel e novos conteúdos acompanhe o meu trabalho no site:
www.academicosdoexcel.com.br

Também compartilho o conteúdo no meu Blog no ambiente Profes.

Um grande abraço,

Professores particulares de Excel

+ Ver todos
Encontre e contrate um professor particular para te ajudar nos estudos.
São Paulo / SP
Graduação: Processamento de Dados (Fatec Sorocaba)
Excel para Iniciantes Excel Avançado Excel Básico Excel em Geral
Porque sim, não é resposta! Então vamos buscá-la e vencer mais essa etapa. Formado em Processamento de Dados pela Fatec Sorocaba, participei de projetos para ensino de crianças e adolescentes, principalmente com aulas de informática. Hoje atuo com o Analista de Sistemas em Instituição Financeira, co ...
Oferece aulas online (sala profes)
Oferece aulas presenciais
R$ 40 / aula
Conversar Whatsapp do professor Marzi O. Whatsapp do professor Marzi O. WhatsApp
1ª aula demonstrativa
Responde em 1 dia e 4 h
Pindamonhangaba / SP
Graduação: letras/literatura (anhagura educacional)
Planilhas Construir Gráficos em Excel Excel em Geral Review no Excel Atingir Meta em Excel (Goal Seek) Excel Avançado Excel Intermediário
Professor de informática com mais de 20 anos de experiencia de mercado O meu nome é Andre Luis, professor de informática desde 2008 onde trabalhei para diversas empresas e instituições como professor de informática. Atuamente eu trabalho para a Udemy publicando cursos online de tecnologia. Dou pale ...
Oferece aulas online (sala profes)
Oferece aulas presenciais
R$ 40 / aula
Conversar Whatsapp do professor Andre L. Whatsapp do professor Andre L. WhatsApp
1ª aula demonstrativa
Responde em 1 h e 14 min
6 avaliações
São Vicente / SP
Curso Técnico: Técnico em Contabilidade (Colégio Independência - Santos/SP)
Excel Profissional Excel Avançado Excel em Geral
Teste Curso JR EXCEL, Controle Finanças Pessoais, Agenda Virtual e um Controle Geral para aprender técnicas e desenvolver planilhas diferenciadas. Oi, sou Jose Ricardo Cunha de Oliveira, nascido em Santos-SP. Sou Técnico em Contabilidade formado em 1973. Atualmente concursado e exercendo atividade na ...
Oferece aulas online (sala profes)
Oferece aulas presenciais
R$ 40 / aula
Conversar Whatsapp do professor Jose R. Whatsapp do professor Jose R. WhatsApp
1ª aula demonstrativa
Responde em 8 min

Pergunte aos nossos professores

Você possui uma lista de exercícios ou Trabalho?

Se seu problema for dificuldade em uma lista de exercícios, revisão de teses e dissertações, correção de textos ou outros trabalhos, peça uma ajuda pelo Tarefas Profes.

Enviar Tarefa